Los drivers USB del Kernel Linux están repletos de vulnerabilidades

Vulnerabilidades USB kernel linux

Drivers USB del Kernel Linux están repletos de vulnerabilidades

Hace algunas horas, un investigador de seguridad de Google informaba a la comunidad Linux de la existencia de 14 vulnerabilidades dentro del apartado de controladores USB del Kernel Linux. Estas vulnerabilidades se pueden explotar fácilmente con una memoria USB maliciosa y puede permitir a un atacante tomar el control total de la máquina vulnerable.

Estas no son las únicas vulnerabilidades encontradas en los controladores USB del Kernel Linux

Estas 14 vulnerabilidades no son las únicas que se han encontrado en este apartado del sistema operativo, sino que la lista es mucho más grande. En el siguiente repositorio de GitHub podemos encontrar una completa lista con un total de 79 vulnerabilidades encontradas, solo en el último mes, en los drivers USB del Kernel Linux.

La mayoría de estos fallos de seguridad permiten realizar ataques DoS a la máquina, dejándola sin servicio, así como ejecutar código malicioso en la memoria que pueda poner en peligro la integridad de la misma.

Relacionado:  Estudiante condenado a 10 años de cárcel por Software espía que afectó 16.000 ordenadores

Este no es el único investigador de seguridad obsesionado por la seguridad de los drivers USB de Linux. A principios de este año, varios investigadores de la University of London hicieron pública una herramienta, llamada POTUS,diseñada para buscar vulnerabilidades en los drivers USB de Linux.

En 2016, los expertos de seguridad encontraron ya vulnerabilidades en este componente de Linux, y además, expertos de seguridad aseguran que muchas de ellas han estado presentes en el sistema desde 2003, poniendo en peligro a los usuarios ante fallos de seguridad que pueden permitir, como decimos, desde la ejecución de código hasta recoger información almacenada en la memoria.

La causa de estas vulnerabilidades es una mala auditoría

La mayoría de los fallos que permiten explotar estas brechas de seguridad son, casi siempre, fallos causados por despistes que, de haberse auditado antes de incluirlos en el Kernel se hubieran podido subsanar muy fácilmente.

El Kernel Linux, concretamente todo lo relacionado con los controladores de dispositivos USB (una gran parte del mismo) debería pasar una serie de auditorías de seguridad con el fin de poder detectar y solucionar cuanto antes todos estos fallos, ahora conocidos, y los fallos que aún están por conocer, ya que, igual que un experto de seguridad puede utilizar POTUS para localizar vulnerabilidades, un pirata informático también puede hacer uso de esta herramienta.

Eso sí, siempre nos quedará el consuelo de que para poder aprovecharse de estas vulnerabilidades el atacante debe tener acceso físico a la máquina de cara a poder conectar el dispositivo USB malicioso en el equipo para empezar a explotar el fallo, por lo que de forma remota no se pueden explotar estas vulnerabilidades.

Fuente: bleepingcomputer

También te podría gustar...

Inline

¿te gusta? Regalanos un Like!

Inline

¿te gusta? Regalanos un Like!